ISE 4 Tutorial
The shadow X shown above is a trademark of Xilinx, Inc.
Re. 34,363, Re. 34,444, and Re. 34,808. Other U.S. and foreign patents pending. Xilinx, Inc. does not represent that devices shown or products described herein are free from patent infringement or from any other third party right. Xilinx, Inc. assumes no obligation to correct any errors contained herein or to advise any user of this text of any correction if such be made. Xilinx, Inc. will not assume any liability for the accuracy or correctness of any engineering or software support or assistance provided to a user.

Xilinx products are not intended for use in life support appliances, devices, or systems. Use of a Xilinx product in such applications without the written consent of the appropriate Xilinx officer is prohibited.

Copyright 1991-2001 Xilinx, Inc. All Rights Reserved.
About This Manual

Manual Contents

The ISE Tutorial is a hands-on learning tool for new users of the ISE software and for users who wish to refresh their knowledge of the software. The tutorial demonstrates basic set-up and design methods available in the PC version of the ISE software. By the end of the tutorial, you will have a greater understanding of how to implement your own design flow using the ISE software.

In the ISE Tutorial, you will create a new project called Tutorial, in which you will design a 4-bit counter module, simulate and implement the design, and view the results.

Following the ISE Tutorial, an appendix, EDIF Design, demonstrates how to implement an existing netlist using the ISE software.
Additional Resources

For additional information, go to http://support.xilinx.com. The following table lists some of the resources you can access from this Web site. You can also directly access these resources using the provided URLs.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description/URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tutorials</td>
<td>Tutorials covering Xilinx design flows, from design entry to verification and debugging <a href="http://support.xilinx.com/support/techsup/tutorials/index.htm">http://support.xilinx.com/support/techsup/tutorials/index.htm</a></td>
</tr>
<tr>
<td>Answers Database</td>
<td>Current listing of solution records for the Xilinx software tools Search this database using the search function at <a href="http://support.xilinx.com/support/searchtd.htm">http://support.xilinx.com/support/searchtd.htm</a></td>
</tr>
<tr>
<td>Application Notes</td>
<td>Descriptions of device-specific design techniques and approaches <a href="http://support.xilinx.com/apps/appswal.htm">http://support.xilinx.com/apps/appswal.htm</a></td>
</tr>
<tr>
<td>Data Book</td>
<td>Pages from <em>The Programmable Logic Data Book</em>, which contains device-specific information on Xilinx device characteristics, including readback, boundary scan, configuration, length count, and debugging <a href="http://support.xilinx.com/partinfo/databook.htm">http://support.xilinx.com/partinfo/databook.htm</a></td>
</tr>
<tr>
<td>Xcell Journals</td>
<td>Quarterly journals for Xilinx programmable logic users <a href="http://support.xilinx.com/xcell/xcell.htm">http://support.xilinx.com/xcell/xcell.htm</a></td>
</tr>
<tr>
<td>Technical Tips</td>
<td>Latest news, design tips, and patch information for the Xilinx design environment <a href="http://support.xilinx.com/support/techsup/journals/index.htm">http://support.xilinx.com/support/techsup/journals/index.htm</a></td>
</tr>
</tbody>
</table>
Conventions

This manual uses the following conventions of style. An example illustrates most conventions.

Typographical

The following conventions are used for all documents.

- **Courier font** indicates messages, prompts, and program files that the system displays.

  speed grade: - 100

- **Courier bold** indicates literal commands that you enter in a syntactical statement. However, braces “{ }” in Courier bold are not literal and square brackets “[ ]” in Courier bold are literal only in the case of bus specifications, such as bus [7:0].

  \texttt{rpt\_del\_net=}

**Courier bold** also indicates commands that you select from a menu.

**File → Open**

- **Italic font** denotes the following items.
  - Variables in a syntax statement for which you must supply values
    
    \texttt{edif2ngd design\_name}
  
  - References to other manuals

    See the Development System Reference Guide for more information.
Emphasis in text

If a wire is drawn so that it overlaps the pin of a symbol, the two nets are not connected.

Square brackets “[ ]” indicate an optional entry or parameter. However, in bus specifications, such as bus [7:0], they are required.

\texttt{edif2ngd [option\_name] design\_name}

Braces “{ }” enclose a list of items from which you must choose one or more.

\texttt{lowpwr =\{on|off\}}

A vertical bar “|” separates items in a list of choices.

\texttt{lowpwr =\{on|off\}}

A vertical ellipsis indicates repetitive material that has been omitted.

IOB #1: Name = QOUT'

IOB #2: Name = CLVIN'

...

A horizontal ellipsis “...” indicates that an item can be repeated one or more times.

\texttt{allow block block\_name loc1 loc2 ... locn;}

Online Document

The following conventions are used for online documents.

- **Blue text** indicates cross-references within a book. Red text indicates cross-references to other books. Click the colored text to jump to the specified cross-reference.

- **Blue, underlined text** indicates a Web site. Click the link to open the specified Web site. You must have a Web browser and internet connection to use this feature.
# Contents

## About This Manual
- Manual Contents .................................................................v
- Additional Resources .........................................................vi

## Conventions
- Typographical .................................................................vii
- Online Document ............................................................viii

## ISE Tutorial
- Tutorial Overview ...........................................................1-2
- Getting Started .................................................................1-3
  - Software Requirements ..................................................1-3
  - Starting the ISE Software ..............................................1-3
  - Accessing Online Help ..................................................1-3
- Design Entry (VHDL) ........................................................1-4
  - Creating a New Project ..................................................1-4
  - Creating a Counter Module .........................................1-5
  - Modifying Counter Module with Counter Template ..........1-6
- Simulating the Behavioral Model ......................................1-9
  - Creating a Testbench Waveform Source .........................1-9
  - Initializing Counter Inputs ..........................................1-10
  - Generating the Expected Simulation Output Values ..........1-11
  - Simulating with ModelSim ...........................................1-12
    - Behavioral Simulation .............................................1-12
    - Post-place and Route Simulation ...............................1-14
- Design Entry (Top-Level Schematic) .................................1-16
  - Creating a Schematic Symbol for the VHDL Module ..........1-16
  - Creating a New Top-Level Schematic .........................1-16
  - Instantiating VHDL Modules ......................................1-16
  - Wiring the Schematic ..................................................1-18
  - Adding Net Names to Wires ........................................1-19
  - Creating Buses ..........................................................1-21
  - Adding I/O Markers .....................................................1-22
- Design Implementation ....................................................1-25
  - Running Implement Design .........................................1-25
  - Viewing the Design in Floorplanner .............................1-26
Simulating the Top-level Design ...................................................1-28
Creating a Testbench Waveform Source .................................1-28
Initializing Counter Inputs .........................................................1-28
Generating the Expected Responses ......................................1-29
Post-place and Route Simulation .............................................1-31

Appendix: EDIF Design

Design Entry ..................................................................................A-1
Creating a New Project ...............................................................A-1
Adding the EDIF source file .......................................................A-2
Design Implementation .................................................................A-3
Running Implement Design ..........................................................A-3
Viewing the Design in FPGA Editor ............................................A-4

Index
The ISE Tutorial describes and demonstrates how to use the VHDL and schematic design entry tools, how to perform behavioral and timing simulation, and how to implement a design.

**Note** This tutorial is designed for ISE 4.x, PC version.

This tutorial contains the following sections.

- “Tutorial Overview”
- “Getting Started”
- “Design Entry (VHDL)”
- “Simulating the Behavioral Model”
- “Design Entry (Top-Level Schematic)”
- “Design Implementation”
- “Simulating the Top-level Design”

To learn how to import your own netlist into ISE and view the design, see “Appendix: EDIF Design.”

For an in-depth explanation of the ISE design tools, see the ISE In-Depth Tutorial on the Xilinx web site ([http://www.support.xilinx.com/support/techsup/tutorials/](http://www.support.xilinx.com/support/techsup/tutorials/)).
Tutorial Overview

Once you have completed the tutorial you will know how to do the following:

- Create a project with a Virtex device.
- Create a VHDL module for a 4-bit counter using the ISE Language Templates.
- Create a testbench waveform source used to simulate the behavior of the 4-bit counter.
- Create a top-level schematic design.
- Instantiate two VHDL counter modules into the top-level schematic design.
- Wire modules together and add net names, buses, and I/O markers.
- Apply timing constraints, input initialization and response constraints to the 4-bit counter waveform, and to the top-level schematic waveform.
- Perform behavioral and timing simulations on the 4-bit counter, and timing simulation on the top-level schematic design.
- View the placed and routed design in the Floorplanner.
- Import your own netlist (EDIF file) in “Appendix: EDIF Design.”
- View the placed and routed design in FPGA Editor in “Appendix: EDIF Design.”
Getting Started

This section describes the software requirements for this tutorial, how to start up the PC version of the software and how to access online help resources.

Software Requirements

To follow along with this tutorial, you will need the following software installed:

- ISE 4.x
- ModelSim VHDL

For more information about installing Xilinx software, see ISE Release Notes and Installation Guide.

Starting the ISE Software

For PC users, start ISE from the Start menu by selecting Start → Programs → Xilinx ISE 4.x → Project Navigator.

Note Your start-up path is set during the installation process and may differ from the one above.

Accessing Online Help

At any time during the tutorial, you can access online help for further information on a variety of topics and procedures in the ISE software. Online help is available by pressing F1. When you press F1, the help system for the tool in which you are working is launched. For example, when you press F1 while in ECS, ECS help is displayed.
Design Entry (VHDL)

In this section, you will create a 4-bit counter module using the Language Templates. To do so, first create a new project and counter module, then modify the counter module with the counter template.

Creating a New Project

To create a new project:

1. Select File → New Project.

2. In the New Project dialog box, type the desired location in the Project Location field, or browse to the directory under which you want to create your new project directory using the browse button next to the Project Location field.

3. Enter ‘Tutorial’ in the Project Name field.
   When you enter ‘Tutorial’ in the Project Name field, a Tutorial subdirectory is automatically created in the directory path in the Project Location field. For example, for the directory path D:\My_Projects, entering the Project Name ‘Tutorial’ modifies the path to be D:\My_Projects\Tutorial.

4. Use the pull-down arrow to select the Value for each Property Name. Click in the field to access the pull-down list.
   Change the values as follows:
   - Device Family: Virtex
   - Device: xcv50-6bg256
   - Design Flow: XST VHDL
5. Click **OK**.

ISE creates and displays the new project in Project Navigator.

**Creating a Counter Module**

Next, create a VHDL module for a counter. To create a counter module:

1. Select **Project → New Source**.
2. Select VHDL Module as the source type.
3. Type in the file name ‘counter’.
4. Click **Next**.
5. Click **Next**.
6. Click **Finish** to complete the new source file template.

Counter.vhd, which is displayed in the HDL Editor window, contains the library declaration and use statements along with the empty entity and architecture pair for the counter you have just created.
Modifying Counter Module with Counter Template

To complete the counter module, insert port declarations and the behavioral code for the counter from the ISE Language Template.

1. Open the Language Templates by selecting **Edit → Language Templates** or by clicking the light bulb icon located on the far right on the toolbar.

2. In the Language Templates window, click the + sign next to VHDL to expand the hierarchy and then click the + sign next to Synthesis Templates.

![Counter Language Template](image)

3. Click and drag the Counter template from the VHDL Synthesis Templates folder, a subset of the VHDL folder, and drop it into counter.vhd between the begin and end behavioral statements.
4. Close the Language Templates window.

5. Cut the port definitions from the comment section of the counter.vhd file and paste them into the parentheses in the port declaration of the counter entity. The port definitions are the following lines:

   -- CLK: in STD_LOGIC;
   -- RESET: in STD_LOGIC;
   -- CE, LOAD, DIR: in STD_LOGIC;
   -- DIN: in STD_LOGIC_VECTOR(3 downto 0);
   -- COUNT: inout STD_LOGIC_VECTOR(3 downto 0);

6. Uncomment the above port definitions in your counter.vhd file by removing the dashes from the beginning of the line.

7. Remove the semicolon that follows the COUNT port definition.

   COUNT: inout STD_LOGIC_VECTOR(3 downto 0)

8. Save counter.vhd by selecting **File → Save**.

Your counter.vhd source should look like the following.
Figure 1-3 Modified Counter Module
Simulating the Behavioral Model

In this section, you will create a testbench waveform that defines the desired functionality for the counter module. This testbench waveform is then used in conjunction with ModelSim to verify that the counter design meets both behavioral and timing design requirements.

Creating a Testbench Waveform Source

First, create a testbench waveform in Project Navigator which you will modify in HDL Bencher.

1. Select the counter (counter.vhd) in the Sources in Project window.
2. Select Project → New Source.
3. In the New dialog box, select Test Bench Waveform source type.
4. Type the name ‘counter_tbw’.
5. Click Next.

   Note In other projects, you can associate your testbench waveform with other sources.

6. Click Next.
7. Click Finish.

HDL Bencher is launched and ready for timing requirements to be entered.

You will now specify the timing parameters used during simulation. The clock high time and clock low time together define the clock period for which the design must operate. The Input setup time defines when inputs must be valid. The Output valid delay defines the time after active clock edge when the outputs must be valid.

For this tutorial, you will not change any of the default timing constraints. The default Initialize Timing settings are the following:

Clock high time: 50 ns
Clock low time: 50 ns
Input setup time: 10 ns
Output valid delay: 10 ns

8. Click OK to accept the default timing constraints.
Your testbench waveform should look like the following.

![Figure 1-4 Testbench waveform in HDL Bencher](image)

**Initializing Counter Inputs**

In the waveform in HDL Bencher, initialize the counter inputs as follows. Verify your entries using the figure below.

**Note** Enter the input stimulus in the blue area in each cell.

1. Click the RESET cell under CLK cycle 1 until the cell is set high.
2. Click the RESET cell under CLK cycle 2 until the cell is reset low.
3. Click the CE cell under CLK cycle 3 until it is set high.
4. Click the DIR cell under CLK cycle 2 until the cell is set high.

Your testbench waveform should now look like the following.

![Figure 1-5 HDL Bencher Stimulus and Response Entries](image)

5. Save your testbench waveform by selecting **File → Save Waveform** or by clicking the Save Waveform icon in the toolbar.

Next, HDL Bencher will prompt you to set the number of clock cycles for which you wish to simulate.
6. Enter 8 in the dialog box: ‘End the testbench ___ cycles after the last input assignment’. Default value is 1.
   This extends the waveform 8 clock cycles past the assertion of CE high.
7. Click OK.
8. Exit HDL Bencher.

The new testbench waveform source (counter_tbw) is automatically added to the project.

**Generating the Expected Simulation Output Values**

Now you can generate the expected outputs for the counter module based on the initialized inputs you have entered.
1. Select counter_tbw.tbw in the Sources in Project window.
2. In the Processes for Current Source window, click the + beside ModelSim Simulator to expand the hierarchy.
3. Double-click Generate Expected Simulation Results.
   This process runs a background simulation using the inputs specified, generating output values which are added to the testbench waveform.
   Your testbench waveform should look like the following.

4. Exit HDL Bencher without saving your waveform.
Simulating with ModelSim

With the expected results generated in HDL Bencher, you are now ready to run your simulation with ModelSim. For this tutorial, you will run a behavioral simulation (also referred to as a functional simulation) and a post-place and route simulation.

**Behavioral Simulation**

Run a behavioral simulation to verify the counter module’s functionality.

1. In Project Navigator, select counter_tbw.tbw in the Sources in Project window.
2. In the Processes for Current Source window, double-click Simulate Behavioral VHDL Model found in the ModelSim Simulator hierarchy.
   
   ModelSim is launched.
3. For first-time users of ModelSim, a dialog box appears in which you:
   - check the Do not show this dialog again option
   - click Run ModelSim

   This dialog box will not appear again until you reinstall or reconfigure ModelSim.

Your simulation results are displayed in the ModelSim wave window.

**Note** ISE automates the simulation process by creating and launching a simulation macro file (an .fdo file). Though not visible to the user, in this tutorial the counter_tbw.fdo file performs the following functions:

- Creates the design library
- Compiles the design and testbench source files
- Invokes the simulator
- Opens all the viewing windows
- Adds all the signals to the Wave window
ISE Tutorial

- Adds all the signals to the List window
- Runs the simulation for the time specified by the Simulation Run Time property (default is 1000 ns)

4. Click Zoom → Zoom Full or click the Zoom Full icon in the toolbar.

5. Click Zoom → Zoom In or click the Zoom In icon in the toolbar.

6. Scroll to the far left of the waveform.

   The output waveform should look like that in Figure 1-7.

![Waveform Image]

**Figure 1-7** Behavioral Simulation Waveform

7. Exit ModelSim by closing the main ModelSim window.
Post-place and Route Simulation

The post-place and route simulation includes timing information for the targeted device. To perform post-place and route simulation on the counter module:

1. In Project Navigator, select counter_tbw.tbw in the Sources in Project window.

2. In the Processes for Current Source window, double-click Simulate Post-Place & Route VHDL Model found in the ModelSim Simulator hierarchy.

   Note This will take the design through place-and-route and back-annotation.

   ModelSim is launched.

3. Click Zoom → Zoom Full or click the Zoom Full icon in the toolbar.

4. Click Zoom → Zoom In or click the Zoom In icon in the toolbar.

5. Scroll to the far left of the waveform.

   The output waveform looks like that in Figure 1-8.
Figure 1-8 Post-place and Route Simulation Waveform

6. Exit ModelSim by closing the main ModelSim window.
Design Entry (Top-Level Schematic)

This section demonstrates how to create a top-level schematic that contains instantiations of the counter module, and describes how to wire together the modules, add net names and buses to the wires, and add I/O markers.

Creating a Schematic Symbol for the VHDL Module

To create a schematic symbol for the VHDL module:

1. In the Sources in Project window, select your counter module, counter.vhd.
2. In the Processes for Current Source window, click the + sign beside Design Entry Utilities and double-click the Create Schematic Symbol process.

   Note This places a schematic component entitled ‘counter’ in the project library.

Creating a New Top-Level Schematic

To create a new top-level schematic:

1. Select Project → New Source
2. Select Schematic as the source type.
3. Type in the name ‘top’.
4. Click Next and then click Finish.

ECS is launched and a blank sheet opens in an ECS schematic window.

Instantiating VHDL Modules

In ECS, instantiate two VHDL counter modules into the top-level schematic.

1. Select Add → Symbol or click the Add Symbol icon in the Tools toolbar.
2. Select counter from the Symbols list in the Symbol browser (to the right of the screen). Do not select any options from the Categories list.

3. Place two counters in the schematic. Click the left mouse button to place a counter on the schematic where the cursor sits.

Your schematic should look like the following diagram.

![Figure 1-9 Instantiated VHDL Modules](image)

4. Press `Esc` to exit Add Symbol mode and restore your cursor.

**Note** Adjust your view using the Zoom option (View → Zoom → In) and the scroll bars in ECS.
Wiring the Schematic

When wiring the schematic symbols, some wires will be left hanging while others will interconnect the modules.

1. To activate the drawing tool, select Add → Wire or select the Add Wire icon from the Tools toolbar.

2. To add a hanging wire or to extend a wire:
   a) Click once at the vertex of a pin on the first counter module.
   b) Extend the wire to the desired length.
   c) Double-click the location you want the wire to terminate.

   **Note** Add a hanging wire to each module pin, according to the diagram Figure 1-10.

3. To connect the wires of the two schematic symbols:
   a) Click once at the vertex of a pin on the second counter module.
   b) Double-click anywhere on the destination wire of the first counter module.

When finished wiring, press Esc to exit Add Wire mode.
After wiring the schematic symbols, you are ready to add net names to the wires.

1. Select **Add → Net Name** or click the Add Net Name icon from the Tools toolbar.

Next, add the following six net names to the schematic: clock, reset, ce, load, dir1, and dir2.
2. To create and place a net name for each hanging wire:
   a) Type the net name in the text box in the right side of the toolbar.

   ![Figure 1-11 Entering the net name](image)

   **Note** Leave the default options Name Branch and Keep Name.

   b) Place the cursor, which now displays the net name, at the end of the hanging wire.

   c) Click the left mouse button.

   With the six net names added, your schematic should look like the following diagram.

   ![Figure 1-12 Schematic With Net Names Added](image)
Creating Buses

Using a similar procedure to adding net names, create buses for the two counter modules by adding bus name and size to the count and din wires.

1. Select Add → Net Names or click the Add Net Name icon from the Tools toolbar.

Next, add the following four buses (name and size) to the schematic: count1(3:0), count2(3:0), din1(3:0) and din2(3:0).

2. To add buses:

a) Type the bus name and size in the text box in the right side of the toolbar; for example, din1(3:0).

Note Leave the default options Name Branch and Keep Name.

b) Place the cursor, which now displays the bus name and size, at the end of the hanging bus.

c) Click the left mouse button.

3. Press Esc to exit Add Net Name mode.

After adding the bus names to the counters, your schematic diagram should look like the following.
Adding I/O Markers

Next, identify the direction of each signal (represented by a hanging wire) in these two counters. In this tutorial, you will add input and bidirectional signal markers to the schematic diagram. The results are shown in the schematic diagram in Figure 1-14.

To add I/O markers:

1. Select Add → I/O Marker or click the Add I/O Marker icon from the Tools toolbar.
2. Add input markers to the clock, reset, ce, load, dir1 and dir2 wires, and the din1(3:0) and din2(3:0) buses as follows:
   a) Select the Input type radio button from the Options toolbar.
   b) Place the cursor, which now displays the input graphic, at the end of the counter input wire.
   c) Click the left mouse button to add the marker.
   The input graphic is added to the end of the wire, around the net or bus name.
   **Note** Click the cursor at the end of the hanging wire when adding the marker. When an attempt to add a marker is unsuccessful, an error message box appears.

3. Add bidirectional markers to the count wires as follows:
   a) Select the Bidirectional radio button from the Options toolbar.
   b) Click the cursor, which now displays a bidirectional graphic, at the end of the counter outputs.
   c) Click the left mouse button to add the marker.
   Your completed schematic should look like the following diagram.
Figure 1-14 Completed Schematic

4. Save the schematic diagram using **File → Save**.

5. Exit ECS.
Design Implementation

For this tutorial, design implementation covers two tasks: running the Implement Design process in Project Navigator, and viewing the resultant placed and routed design in Floorplanner.

Running Implement Design

First, run all processes (Synthesis through Place & Route) associated with the counter. To do so, run Implement Design on the schematic file:

1. Select top (top.sch) in the Sources in Project window.

This runs all processes.

Figure 1-15  Implement Design processes

A check mark in the Processes for Current Source denotes a process that was run successfully. An exclamation mark indicates that the process was run and that there is a warning for the process. More information about warnings can be obtained in the Transcript window.
Viewing the Design in Floorplanner

Now, you can view the implemented design in the Floorplanner.

1. Select top (top.sch) in the Sources in Project window.

2. In the Processes for Current Source window, click the + sign beside Implement Design and the + sign beside Place & Route.

3. Double-click View/Edit Placed Design (Floorplanner).

Floorplanner is launched and displays the placement of the design for the project.

To view the implemented design results in a more meaningful way, you can display and zoom in on the input/output signals.

1. In the top.fnf Design Hierarchy window (View → Hierarchy), select the top-level hierarchy, ‘top (22 IOBs, 13 FGs, 8 CYS, 8 DFFs, 1 BUFG)’, to show the signals in the Placement window.

   **Note** Alternatively, you can draw a rectangle around the design area in the Placement window to show the signals.

2. Select View → Zoom → To Selected or click the Zoom to Selected icon (the last icon on the far right of the toolbar) in the Floorplanner toolbar.

3. Verify that all the I/Os are accounted for by holding the cursor over each of the pads and reading the pad name in the lower left corner of the Floorplanner window.

   **Note** Alternatively, you can view isolated signals in the placement window by selecting individual signals from the list in the top.fnf Design Hierarchy window.

The placement in Floorplanner should look like the following.
When you have finished viewing the implemented design, save the Floorplanner design view using **File → Save** and exit Floorplanner.
Simulating the Top-level Design

Next, run a timing simulation on the top-level design created in the previous sections. First, create a testbench waveform for the top-level design using HDL Bencher, and then simulate the top-level design using ModelSim.

Creating a Testbench Waveform Source

Create a testbench waveform which you will modify in HDL Bencher.

1. In Project Navigator, select top (top.sch) in the Sources in Project window.
2. Select Project → New Source.
3. In the New dialog box, select Test Bench Waveform source type.
4. Type the name ‘top_tbw’.
5. Select Next.
6. Ensure top is the associated source and select Next.
7. Select Finish.

HDL Bencher is launched.
8. Click OK to use the default timing constraints for the testbench waveform.

Initializing Counter Inputs

In the waveform in HDL Bencher, initialize the counter inputs as follows. Verify your entries using Figure 1-17.

Note Enter the input stimulus in the blue area in each cell.

1. Click the ce cell under clock cycle 3 until it is set high.
2. Click the dir1 cell under clock cycle 2 until it is set high.
3. Click the dir2 cell under clock cycle 1 until it is set high.
4. Click the dir2 cell under clock cycle 2 until it is set low.
5. Click the reset cell under clock cycle 1 until it is set high.
6. Click the reset cell under clock cycle 2 until it is set low.
Generating the Expected Responses

To generate the expected response, make the following response entries in the yellow areas in the waveform in HDL Bencher.

1. Click the yellow count1(3:0) cell under clock cycle 2.
2. Click the Pattern button to launch the Pattern Wizard.
3. Set the parameters in the Pattern Wizard dialog box so that the expected output counts from 0 to 7 as follows:

![Pattern Wizard Settings](image)

Figure 1-18  Pattern Wizard Settings
4. Click **OK** in the Pattern Wizard dialog box.

5. Click the yellow count2(3:0) cell under clock cycle 2 and enter 0 (zero).

6. Click the yellow count2(3:0) cell under clock cycle 3.

7. Click the Pattern button to launch the Pattern Wizard.

8. Set the pattern wizard parameters so that the expected output counts from 15 to 9 as follows:

9. Click **OK** in the Pattern Wizard dialog box.

The testbench waveform should look like the following.
10. Save the testbench waveform by selecting **File → Save Waveform** or by clicking the Save Waveform icon in the toolbar.

11. Exit HDL Bencher.

In the Source for Project window in the Project Navigator, the new testbench waveform file is a subset of top (top.sch).

**Post-place and Route Simulation**

To perform post-place and route simulation on the top-level design:

1. In the Project Navigator, select top_tbw.tbw in the Sources in Project window.

2. In the Processes for Current Source window, double-click Simulate Post-Place and Route VHDL Model found in the ModelSim Simulator hierarchy.

   ModelSim is launched with the back-annotated design.

3. Click **Zoom → Zoom Full** or click the Zoom Full icon in the toolbar.
4. Click **Zoom → Zoom In** or click the Zoom In icon in the toolbar and scroll to the far left of the waveform.

   ![Waveform Image]

   The waveform should look like the following.

   **Figure 1-21 Timing Simulation Waveform**

5. Verify that the time simulation passes a 10ns clock time delay.

6. When you have finished analyzing your results, exit ModelSim by closing the main ModelSim window.
Appendix: EDIF Design

This appendix explains how to implement a design in ISE from an EDIF source file.

This appendix contains the following sections.

- “Design Entry”
- “Design Implementation”

Design Entry

To add an EDIF source file to a new project in Project Navigator, first create a new project and add the EDIF source file, then implement the design.

Creating a New Project

To create a new project:

1. Select File → New Project.
2. In the New Project dialog box, type the desired location in the Project Location field, or browse to the directory under which you want to create your new project directory using the browse button next to the Project Location field.
3. Enter ‘TutorialEDIF’ in the Project Name field.

When you enter ‘TutorialEDIF’ in the Project Name field, a TutorialEDIF directory is automatically created in the directory path in the Project Location field. For example, for the directory path D:\My_Projects, entering the Project Name ‘TutorialEDIF’ modifies the path to be D:\My_Projects\TutorialEDIF.
4. Use the pull-down arrow to select the Value for each Property Name. Click in the field to access the pull-down list.
   
   Change the values as follows:
   
   ♦ Device Family: Virtex
   ♦ Device: xcv300-6bg352
   ♦ Design Flow: EDIF

5. Click **OK**.

![Figure A-1  New Project Dialog Box](image)

ISE creates a subdirectory and a new project in Project Navigator.

**Adding the EDIF source file**

Now, add an EDIF source file to the new project. The EDIF source file used in this tutorial is an example file that is shipped with the ISE software. To add the example file to the project:

1. Select **Project → Add Source**.
2. Browse to the following directories found in the Xilinx install directory:
   
   `/ISEexamples/edif_flow/`

3. Select the file ‘mf.edn’.
4. Click **Open**.

The file is now added to the new project.
Note To add a copy of the EDIF netlist in the new project directory rather than the original file, select the Project \(\rightarrow\) Add Copy of Source option instead of Project \(\rightarrow\) Add Source.

Design Implementation

Next, implement the design and use FPGA Editor to view the placed and routed design.

Running Implement Design

To run design implementation on the design:

1. Select the netlist ‘mf.edn’ from the Sources in Project window.

   This runs all processes (Translate through Place & Route) required to view the implemented design in FPGA Editor.

   ![Processes for Current Source](image)

   **Figure A-2 Implement Design processes**

A check mark in the Processes for Current Source denotes a process that was run successfully. An exclamation mark indicates that the process was run and that there is a warning for the process. More information about warnings can be obtained in the Transcript window.
Viewing the Design in FPGA Editor

To view the design in FPGA Editor:

1. When implementation is finished, in the Processes for Current Source window, click the + sign beside Implement Design and click the + sign beside Place & Route.

2. Double-click the View/Edit Routed Design (FPGA Editor).
   The placed design, mf.ncd, is automatically displayed in FPGA Editor.

3. Click on the Type column header in the List1 window to list all components by type. Resize the table and the columns as desired to read the column names clearly. Verify that all 26 I/Os are accounted for in the Type column.

   **Note** Clock I/Os will be listed under the GCLK type, not the IOB type.

   ![Figure A-3 Listing all components by type](image)

When finished viewing the design, exit FPGA Editor.
Index

B
behavioral simulation
   with HDL Bencher, 1-11, 1-29
   with ModelSim, 1-12
buses, creating in schematics, 1-21

C
comment lines, 1-7
costraints
timing, 1-9, 1-28

D
design entry
   EDIF netlist, A-1
   schematics, 1-16
   VHDL counter module, 1-4
design implementation
   example, 1-25, A-3

E
EDIF
   source file, A-2

F
Floorplanner
   viewing design, 1-26
FPGA Editor
   viewing design, A-4

H
HDL Bencher
   creating waveform, 1-9, 1-28

I
I/O markers, adding, 1-22
instantiation
   VHDL modules, 1-16
ISE software, starting, 1-3

L
Language Templates, 1-6

M
markers, adding, 1-22
ModelSim, simulation, 1-12, 1-31

N
net names
   adding to wires, 1-19
new project, creating
   EDIF design flow, A-1
   VHDL design flow, 1-4

O
online help, 1-3
**P**
Project Location field, 1-4, A-1
Project Name field, 1-4, A-1
Property Name field, 1-4, A-2

**S**
schematic symbols, creating, 1-16
schematics
  adding I/O markers, 1-22
  creating buses, 1-21
  instantiating VHDL modules, 1-16
  wiring, 1-18
simulation
  behavioral, 1-11, 1-12, 1-29
  timing, 1-14, 1-31
starting, ISE software, 1-3

**T**
testbench. See waveform
timing constraints, 1-9
timing simulation, 1-14, 1-31
top-level schematics, 1-16

**V**
VHDL modules
  creating, 1-5
  creating schematic symbols, 1-16
  instantiating in schematics, 1-16

**W**
waveform
  creating, 1-9, 1-28
wires
  in schematics, 1-18