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Advanced Queries:  
Moving Beyond the Select Query 

Instructor: Edwin V. Bonilla 

Based on slides by 
Robert Grauer, Keith Mast, Mary Anne Poatsy 

 



COMP1000   © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Access Chapter 7  slide 2  

Objectives 
•  Determine when to use an action query 
•  Update data with an update query 
•  Add records to a table with an append query  
•  Create a table with a make table query 
•  Delete records with a delete query 
•  Create a parameter query to provide flexibility 
•  Summarize data with a crosstab query  
•  Find unmatched records with a query 
•  Find duplicate records with a query 
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Action Queries 
•  Alternative to the Select query, which 

fetches information for display 
•  Will perform an action to change data 
•  Start by making Select query, and then 

change type to: 
– Update 
– Append 
– Make table 
– Delete 

3 
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Action Queries 

•  Can use criteria just as Select queries 
can 

•  Often run in the background (not always 
on command) 

•  Can cause problems with data loss 
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Action Queries:  Examples 
•  Append query —	  used to copy records to 

an existing table 
– Example:  Copy graduated students from 

Students table to Graduated table in a student 
database 

•  Delete query —	  used to remove records 
– Example: Delete graduated students from 

Students table after they are copied to 
Graduated table 

•  No “move” query; this is how we simulate a 
move 
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Action Queries:  Examples 
•  Update query —	  used to make changes 

– Example:  One customer service rep leaves, and 
all clients assigned to that rep must be changed 
to someone else 

•  Make table query —	  used to copy information 
to a new table 
– Example:  Move all inactive customers to a new 

table 
– Pair with delete query to remove old records 
– Can help keep Customers table fast and efficient 

•  Queries on smaller tables will be quicker 
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Action Queries:  Locations 

Make	  Table	  

Append	  

Update	   Delete	  

Loca4ons	  of	  Ac4on	  Queries	  on	  Query	  Tools	  Design	  Tab	  
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Action Queries:  Locations 

Make	  
Table	  

Append	   Update	  

Loca4ons	  of	  Ac4on	  Queries	  on	  Query	  Tools	  Design	  Tab	  

Delete	  Select	  
Default	  
Query	  
Type	  
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Action Queries: Warnings 
•  Important to backup database first 

– Can make changes that cause unintended 
changes 

•  Access prompts with the number of records to 
change 
– Ensure number sounds correct 

•  Verify table data afterwards 
– Did it change what you thought it would change? 

•  Do not re-run 
– Especially with Update queries, updates that are 

calculations can cause unintended changes 
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Update Query 
•  Used to automate changes to a 

database 
– No need to do by hand 

•  Change the value of one or more fields 
automatically  

•  Can be based on criteria (single or 
multiple) 
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Update Query:  Examples 
•  All athletes with grade point averages 

greater than 2.5 should have the 
Eligible field set to Yes 

•  West Paterson, NJ changed their name 
to Woodland Park 
– All customers who have a City field of West 

Paterson and a State of NJ should have 
the City field changed to Woodland Park 
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Append Query 

•  Selects records from one or more tables 
and adds them to existing table 

•  Destination table must exist 
– If not, use a Make Table query 
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Append Query 

•  Must match source fields with 
destination fields 

•  Data types must match 
– Cannot append a date field in to a numeric 

field 
– Exceptions: Numeric and Date fields can 

both be appended to a Text field 
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Append Query 
•  Validation rules in the destination table 

still apply 
– Could not duplicate primary key 

•  Any non-required, missing fields will be 
blank 
– If you append four fields to a five-field 

table, fifth field will be blank 
•  Destination table should NOT contain 

an Autonumber 
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Make Table Query 
•  Selects records from one or more tables 
•  Uses results to create a new table 

– Similar to append query, except results go 
to new table 

– Avoids issues with having to match data 
types 

•  If destination table exists, Access will 
prompt you to delete the existing table 
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Delete Query 
•  Selects records and then removes them 

from a table 
•  Permanently removes records 

– Use with caution 
– Backup database first 

•  May be done after a Make Table or 
Append query to simulate a move 
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Delete Query 

•  You need to know the following to 
create a Delete query: 
–  What are the criteria that should be met 

for to records to be deleted 
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Action Query Demo 1 
•  Open a07h1replace.accdb, save as a07h1replace_demo.accdb 
Backup database before testing an action query! 
•  File > Save & Publish > double-click Back Up Database 
•  Paranoia rules here: check backup exists and size is sensible. 
Create an Update Query 
•  Click Create > Query Design 
•  Double-click Inventory, Pattern, Manufacturer tables, close dialogue 
•  Add SKU, OnHandQty, & Retail fields from Inventory, MfgID from Pattern, 

& Alias from Manufacturer. 
•  Type 801190 in Criteria row of MfgID 
•  Switch to Datasheet view – should be 1129 Spode China records. 
•  In Design view; click MfgID column, & Query Setup > Insert Columns 
•  Type Value: [OnHandQty]*[Retail] in new column top row, make it Currency 
•  Switch to Datasheet, Click Records > Totals, click in Total row & Value 

column, select Sum 
•  Total should be $911,415.88. This, times 1.05, would be $956,986.67. 
•  Click View, click Query Type > Update. Change Update To row under Retail 

to [Retail]*1.05. Set it to Currency. 
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Action Query Demo 1 (cont’d) 
Test an Update Query 
•  Switch to Datasheet view, and note values before update 

(2nd one is 10.00) 
•  Return to Design view. Click Run. Click Yes to the 

warning. 
•  Switch to Datasheet view again, and check the values 

(2nd one is now 10.50) 
•  Return to Design view. Click Query Type > Select. Switch 

to Datasheet view. 
•  Total at bottom of Retail column is now $956,986.67 (cf. 

previous slide) 
•  Return to Design view, Click Update to change back to an 

update. 
•  Save query as Spode China Price Upgrade. Close all 

open objects. 
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Action Query Demo 2 
Create an Append Query 
•  File > Save & Publish > Back Up Database 
•  Open New Employees table in Datasheet mode, add a new record: 

8966000, 0626266, name, address, phone, and 9/11/2012 as HireDate. 
Close table. 

•  Open Employees: note 115 records, close. 
•  Click Create > Query Design. Double-click New Employees, close 

dialogue. 
•  Click Query Type > Append. Click Table Name, choose Employees, 

check that Current Database option is chosen, click OK. Append To row 
appears. 

•  Double-click title bar of New Employees, drag all fields to 1st field of 
grid. 

•  Click View, should be 4 rows, 10 fields. Click View. Click Run, click Yes. 
•  Open Employees, sort in decreasing order of Hire Date, now 119 

records. 
•  Click Query1 tab, click Save, save as Append New Employees. Close 

all open objects. 
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Action Query Demo 3 
Create a Make Table Query 
•  File > Save & Publish > Back Up Database. 
•  Click Create > Query Design. Double-click Employees, 

close dialogue box. 
•  Double-click title bar of Employees table, drag all fields to 

query grid. 
•  Type Is Not Null in Criteria row of TermDate field. Go to 

Datasheet view. There are 9 terminated employees. 
•  Click View. Click Make Table. Type "Former Employees" in 

Table Name box. Check Current Database option is 
selected. Click OK. Click Run. 

•  Check Navigation pane for new table (Former Employees), 
open new table and confirm there are 9 former employees 
in it. 

•  Save query as Former Employees Make Table 
•  Close query. 
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Action Query Demo 4 
Create a Delete Query to delete the former employees from 
Employees 
•  File > Save & Publish > Back Up Database. 
•  Click Create > Query Design. Double-click Employees, close 

dialogue box. 
•  Drag the * from the Employees table to the first column of the 

query design grid. Takes up one column, but represents all fields. 
•  Drag the TermDate field to column 2. Type Is Not Null I the Criteria 

row of the TermDate field. 
•  Click View. Check there are 9 former employee records there. 
•  Switch to Design view. Click Query Design > Delete. Click Run. 

Click Yes to warning. Save query as Delete Former Employees, 
close. 

•  Open Employees table, check there are now 110 (not 119) 
records. 

•  Compact and Repair Database. 
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Queries for Special Conditions 
•  Four more specialised queries that 

can help a user (or DBA) make 
decisions (or maintain the DB): 
– Parameter query 
– Crosstab query 
– Find Unmatched Records query 
– Find Duplicate Records query 
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Queries for Special Conditions 
•  Parameter query 

– Will prompt the user for a criterion 
•  Example: Prompt user to enter a state code, return 

all customers living in that state 
•  Crosstab query 

– Similar to PivotTable, but no filters 
– Displays aggregate data across two 

dimensions 
– Specify row field, column field, value field, 

what statistic to compute for the value field 
(sum, count, average, …) 
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Queries for Special Conditions 
•  Find Unmatched Records query 

– Example:  Finds child records with no 
matching parent records 
•  In a one-to-many relationship, the “one” is the 

parent record and the “many” is the child 
record 

•  In an Orders database, if one customer places 
many orders, customer is the parent record 
and an order is the child record 
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Queries for Special Conditions 
•  Find Duplicate Records query 

– Can analyze data to find repeated 
information 

– Can find accidental replication of data 
•  Example: Customers can sign up for 

supermarket store cards, to find people who 
have signed up for two you can find people 
with the same name, address, etc. 
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Parameter Query 
•  Create regular Select query 
•  Add prompt to Criteria line, surrounded by 

brackets 
[Instructions] 
e.g. [Enter a year] 

•  User will be prompted with your Instructions 
text and given a dialog box to enter data 

•  If multiple parameters exist, Access will start 
from the leftmost field and move right 
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Parameter Query 

Access	  will	  prompt	  the	  user	  to	  fill	  in	  a	  
value	  for	  the	  parameter	  in	  a	  dialog	  
box	  when	  the	  query	  is	  executed.	  
	  
The	  parameter	  –	  [Enter	  the	  City]	  -‐	  in	  
this	  example	  is	  in	  square	  brackets,	  as	  
required.	  
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Parameter Query 
•  Can be used for partial matches as well 
•  Example: Area Code 

– Prompt user for an area code 
– Return all phone numbers in that area code 
– Enter criterion as 

Like [Enter Area Code] & '*' 

– & is a concatenation operator 
– Results will be all phone numbers starting with 

whatever the user enters 
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Parameter Reports 

•  Reports can be based on queries 
•  To create a Parameter Report, create a 

Parameter query and then base the 
report on the query 
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Crosstab Query 
•  Summarizes a data source using a grid of 

rows and columns 
•  Uses aggregate functions to summarize 

data (sum, count, average, etc) 
•  Resembles a PivotTable, but without filters 
•  Advantages: 

– Source can be tables, queries, or a 
combination of both 

– Can create many of them and save them 
•  Each table can only have one PivotTable 
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Crosstab Query 

•  Column headings display field values 
along the top side 

•  Row headings display field values 
along the left side 

•  Once completed, it can be edited easily 
to add fields, change order, etc. 
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Crosstab Query:  Example 
•  Example: 

– We want to summarize the revenue 
generated by each salesperson 

– We want to see totals for each month 
– We also want to see totals for the entire 

year 
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Crosstab Query 

Two	  row	  
headings	  exist:	  
Last	  Name	  and	  
First	  Name	  

The	  months	  of	  the	  year	  are	  the	  column	  headings	  

Aggregate	  
func4on	  
results	  
show	  here	  	  
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Find Unmatched Records Query 
•  Compares records in two related tables 

and displays the records found in one 
table, but not the other 

•  Requires a common field 
•  Example: Find all applicants to a college 

(stored in Student table) who have 
never registered for a class (found in 
Registration table) 
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Find Duplicate Records Query 
•  Useful to find duplicate values in a table 
•  Can be useful if there may be duplication of 

fields that should not exist 
– Want to add a primary key field 
– Duplicates exist, so primary key can not be 

added 
– Use query to find these duplicates 

•  Will find duplicates, but it is still up to 
Database Administrator to review manually 
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"Special" Queries Demo 1 
Create a Parameter Query 
•  Work with 07h1replace_demo.accdb as before 
•  Click Create > Query Design 
•  Double-click Employee Titles & Employees tables. Close dialogue. 
•  Double-click Description from Employee Titles. Double-click 

FirstName, LastName, HireDate, Phone from Employees. 
•  Click the Criteria row for Description, type [Enter the position]. 
•  Click Run. Enter Parameter Value box opens: type Sales 

Associate 1, click OK. There should be 33 records in the result. 
•  Save query as Employee Phone List by Position. Back to Design 

view 
•  Click Sort row of LastName, choose Ascending, click Run again, 

type Sales Associate 1 again, OK. 
•  Close query, save changes. Double-click Employee Phone List by 

Position query to run it again, enter Customer Service 
Representative, OK. Should be 11 records. Close query. 
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"Special" Queries Demo 2 

Create a Parameter Report 
•  Select Employee Phone List by Position query in Nav pane. 
•  Click Create > Reports > Report. 
•  Type Supervisor, Sales, then OK. 
•  Click the Description column heading to select it. Use mouse 

to reduce column width. Repeat with other fields, so all data 
fits on page (horizontally). Check in Print Preview. 

•  Click Design > Grouping & Totals > Group & Sort. 
•  Click Add a Sort, then LastName 
•  Check again in Print Preview. Close Print Preview. 
•  Close and save report with the name Employee Phone List 

by Position. 
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"Special" Queries Demo 3 

Use the Crosstab Query Wizard 
•  Click Create > Queries > Query Wizard. 
•  Select Crosstab Query Wizard, click OK. 
•  Click Queries in the View section of the dialogue box. Then 

click Query: Revenue Query. Click Next 
•  Row headings: double-click LastName field in Available 

Fields box, click Next. 
•  Column headings: click the State field, click Next 
•  Value field: click Revenue in the Fields box, click Sum in the 

Functions box, click Next 
•  Change query name to Revenue by Salesperson and State. 

Ensure View the query option is selected, click Finish. 
•  Examine results … too much information … 
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"Special" Queries Demo 4 

Edit a Crosstab Query 
•  Click File > Save Object As, type Revenue by LongPatName 

and State, click OK. This makes a copy of the query, to 
modify. 

•  Switch to Design view. 
•  Click arrow in Field row of first column, and then select 

LongPatName. 
•  Click third column (Revenue) then Property Sheet, set format 

to Currency. 
•  Click in "Total of Revenue" field, change format field property 

on the General tab to Currency. Close Property Sheet. 
•  Click Run. Widen LongPatName field so you can see the 

names properly. 
•  Save the changes, then close the query. 
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"Special" Queries Demo 5 

Create a "Find Unmatched" Query using the Wizard 
•  Click Create > Query Wizard > Find Unmatched Query 

Wizard, OK 
•  Click Table: Customer, Next 
•  Click Table: Order Data, Next 
•  Check CustomerNum is Matching field on both tables 
•  Click Next again. 
•  Click >> button to add all fields to the query, Next 
•  Click Finish. 456 customers have not placed an order. 
•  Close Customers Without Matching Order Data query. 
•  Save the changes. 
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"Special" Queries Demo 6 
Create a "Find Duplicate Records" Query using the Wizard 
•  Click Create > Query Wizard > Find Duplicate Query Wizard, 

OK 
•  Click Table: Pattern, Next 
•  Double-click LongPatName in Available Fields box to move it 

to the Duplicate-value fields box, Next. 
•  Click >> button to move rest of fields to the Additional Fields 

box, click Next. 
•  Click Finish, accepting default name for query. 
•  Result shows 4 records showing two duplicate 

LongPatName fields. 
•  Save query, close query. 
•  Compact and Repair Database 
•  Close database. 
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Summary 
In this section, you learned that the Select 
query is just one type of query. You now know 
how to use 
•  make table queries 
•  append queries 
•  update queries, and 
•  delete queries 
to modify the database. 
You also learned how to use special types of 
queries to help make decisions and increase 
the flexibility of your database. 
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