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Forms & Reports 
Instructor: Aarthi Natarajan 

Based on slides by 

Robert Grauer, Keith Mast, Mary Anne Poatsy 
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Creating & Using 

Forms 

Based on slides by 

Robert Grauer, Keith Mast, Mary Anne Poatsy 



COMP1000  © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Access Chapters 3+4  slide 3  

Objectives 

Using the form tools: 

• Creating and modifying a form 

• Sorting records in a form 

• Identifying form sections 

• Revising forms using form views 

• Identifying control types in forms 
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Form Basics 

• Forms — database objects used to add 

data into a table 

• Reasons to use forms rather than tables 

1. Less likely to edit the wrong record by 

mistake 

2. Can show data from more than one table 

simultaneously 

3. Can create Access forms to match paper 

forms 
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Creating Forms Using  

the Form Tools 

• 16 tools for creating 

forms 

• Forms group 

• Navigation forms 

(6) 

• More Forms (6) 
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Identify a Record Source 

• Record source — the table or query that 

supplies the records for a form or report 

– A table gives all its fields; a query is more 

flexible 

– When a table or query is selected, the Form 

tool is no longer greyed out 

• Sketch the form first 

• Then use the Form Tool 
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The Form Tool 

• This is a 
Stacked Form 
(aka Columnar) 

• Use Layout view 
to modify design 
of form 
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Work with a Subform 

• When using the Form tool to create a 
form:  

– Access analyzes the table relationships in the 
database, and may … 

– Automatically add a subform to your form.  

• Subforms — display records with foreign 
key values that match the primary key 
value in the main form. 

– Subforms can be deleted. 
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Create a Split form 
• Split forms — combine two views of the 

same record source 

– One section is displayed in a stacked layout 

– One section is displayed in a tabular layout 

– Use More Forms > Split Form 

 

Bottom section shows 

multiple employees in 

Datasheet view 

Top section shows one 

employee in Form view 

Use the form splitter bar 

to resize each section 
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Create a Multiple Items Form 

• Multiple items form — displays multiple records 
in a tabular layout similar to a table’s Datasheet 
view. 
Use More Forms > Multiple Items 

 

Layout  resembles 

a table’s Datasheet 

view 

Employee records 

are displayed in 

tabular format 
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Create a Datasheet Form 

• Datasheet form 

looks like the datasheet view of the table 

use More Forms > Datasheet 

• Visual Basic for Applications (VBA) 

can be used to enforce more complex data 

checking rules 
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Forms Demo 1 
• Open a04h1coffee, save with another name 

Use the Form tool 

• Click Customers table, Create tab, Forms / Form 

• Three new Form Design Tools tabs appear: Design, Arrange, & 
Format. Unlike other Microsoft applications, where text formatting 
lives in the Home tab, text formatting for forms is under this Format 
tab in Access. 

• Click C0001 box. Resize to half current width. All text boxes resize. 

• Click Arrange tab > Rows & Columns > Select Layout. 

• Click Arrange tab > Position > Control Padding > Narrow 

• Save: "Customer Information", OK. 

• Home > Views > View (Form view). Advance to Lugo Computer… 

• Double-click Customers table in Navigation pane. Check Lugo 
record 

• Click Customer Information tab, change Derek to your name, 
advance to next record. Check Customer table record 6. Back to 
Customer Information, change back to Derek Anderson. 

• Switch to Layout view, change title to Customer Information, Save. 



COMP1000  © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Access Chapters 3+4  slide 13  

Forms Demo 2 
Make a Split Form 

• Click Customers table, Create tab, More Forms > 
Split Form 

• Switch to Form view, click Lugo Computer Sales in 
bottom half. 

• Change email address to your name in upper part. 
Move on & back. 

• Click anywhere in Coulter Office Supplies (bottom). 
Add "xyz" to Contact, email, and Address1 in top half. 
Click anywhere in bottom half to save changes. 
Remove xyzs. 

• Switch to Layout view. Change title to Customers – 
Split View, Save form as Customers – Split View, OK. 

• Adjust splitter bar. 

• Close the form and save the changes. 
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Forms Demo 3 
Make a Multiple Items Form 

• Click Products table, then Create tab, More Forms / Multiple Items. 

• Click cell with P0001. Reduce depth by about 50%. All rows 
changed. 

• Change title to Products – Multiple Items. 

• Click Themes > right-click Technic > Apply theme to this object only 

• Close and save form as Products – Multiple Items. 

Make a Datasheet form, Delete fields from form 

• Click Products table, then Create tab, More Forms / Datasheet 

• Save as Products – Datasheet. Right-click Products – Datasheet in 
Navigation pane, choose Layout view. 

• Click an empty area, click Cost box, Delete, click blank space, 
Delete. 

• Repeat for MarkupPercent. Click Refrigeration Needed, change to 
Refrig? 

• Double-click Products table,  compare. Close table and form. 
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Forms Demo 4 
Add a field to (a table and) a form 

• Right-click Customers table, then click Design view. 

• Click Address1 field, then click Tools group > Insert Rows 

• Type Website into Field Name box, choose Hyperlink as Data 
Type. 

• Close and Save. Right-click Customer Information form, Layout 
view. 

• Click Add Existing Fields, drag Website field to form above 
Address1. 

• Switch to Form view, tab to Website field, type URL, close and 
save. 

Change sorting in a form 

• Open Customer Information form, click Next record arrow a few 
times. Customers are in Customer ID order. 

• Click First record arrow. Click Customer Name field, then 
Ascending in Home> Sort & Filter group. Check order using Next 
record. Close. 

• File > Compact & Repair Database. 
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Create Forms Using  

the Other Form Tools 

• Form Design tool 

• Blank Form tool 

• Navigation option 

• PivotTables and PivotCharts converted to 
Forms 

• Modal Dialog Form tool 
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Modifying a Form 

We'll see how to… 

• Add a field 

• Remove a field 

• Change the order of fields 

• Change the width of a field 

• Modify label text 

• Changing color themes or style 
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Add a Field to a Form 

• Stacked layout 
– Switch to Layout view 

– Click Design>Tools>Add Existing Fields 

– Drag new field to desired place, using orange line guide. 

• Tabular layout 
– As above, but orange line will be vertical, not horizontal 
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Work with a Form Layout Control 

This is a Customer 

information form 

created with the Form 

tool 

It produces a 

Stacked layout 

This Orders 

subform is 

automatically 

added by Access 
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Working with Fields on a Form 

• To delete a field from a form 

– Go to Layout view. Click text box control of 

field. Click Delete. Click empty space left 

behind. Click Delete. 

• To adjust column widths in a form 

– Go to Layout view. Select a box. Grab right 

edge and drag. 
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Sorting Records in a Form 

• To change the sorting in a form 
Open in Form view. Select desired field. Click A-Z 

(Ascending) in Home>Sort&Filter 

• Remove sorting in a form 
Open in Form view. Click Remove Sort icon in 

Home>Sort&Filter 
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Form Sections, Views and 

Controls 
• Form Sections 

• Views 

– Layout view 

– Form view 

– Design view 

• Controls 

Select 

Text 
box 

Label 

Button 

Tab 

Hyperlink 

Web 
browser 

Navigation 

Option 
group 

Page Break 

Combo 
box 

Chart 

Line 

Toggle 

List box 

Rectangle 

Check 
box 

Attachment 

Unbound 
object frame 

• Bound control: 

text box connected to a field in a 

table or query 

• Unbound control: 

label or decorative design element 

• Calculated control 
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Identify Default Form Sections 

• Form header section 

e.g. form title 

• Detail section 

fields, field labels, etc. 

• Form footer section 

often used for totals of field values, e.g. in an 

invoice 

• Modifying the Default Form Sections 

Easiest to 

identify in 

Design view 
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Revising Forms Using Form 

Views 

• Switch between form views by e.g. right-

click form tab 

• Enter or edit data in Form view 

• Alter a form in Layout View 

• Design view provides the most options for 

modifying the form 
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Forms Demo 5 

• Open a04h1coffee_demo, save as a04h2coffee_demo 

Form sections; Alter a form in Design view 

• Select Revenue query, click Create > Form. Grab right edge of 
LastName textbox, reduce field width by ~50%, switch to Design 
view 

• Drag bottom margin of Form Footer bar down until size is 1" 
(2.5cm), switch to Form view, inspect, can't see white-on-white 
change. 

• Back to Design View. Click Form Footer bar. Click Tools/Property 
Sheet, click Format tab, then Back Color arrow (not … button), pick 
Background light header. Switch to Layout view. Footer is visible. 

• Back to Design view. Drag bottom margin of Form Header to ¾" 

• Save (as Revenue) and Close form. 
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Forms Demo 6 

Edit data in Form view 

• Select Products table, click Create tab, click Form. 

• Click anywhere in subform, select Layout view, delete subform. 

• Select Form View. Click Next Record twice in Nav bar … record 3. 

• Change Coffee – Mild Blend to Coffee – Light. 

• Click Last Record, then Previous Record twice, change, Styrofoam 

Cups – 12 ounce to Heavy Paper Cups – 12 ounce. 

• Click in Current Record box in Nav bar, type 12, press Enter. 

• Change Sugar Substitute to Splenda. 

• Click in Search box in Nav bar, type pop, press Enter. 

• Change Popcorn – Plain to Popcorn – Low Calorie. 

• Save as Products, Close. 
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Forms Demo 7 

Work with Controls 

• Right-click Revenue form, click Design view. 

• Click Revenue label in form header, twice, change to Revenue Form. 

• Click Form logo to left of "Revenue Form", press Delete key. 

• Click Controls > Label, click in Form Footer at say (1cm, 1cm) and type 
"This form was created by Donald Duck". 

• Click the Revenue Form label in the form header, then click Home > 
Clipboard > Format brush. Click new label in form footer. Resize box. 

• Click Label, add 2nd label under 1st one. Type Last Revision 7/5/2013. 

• Click form header bar, open Property Sheet. Change Height to 1.5cm 

• Click Revenue Form label, change Height to 1.2cm, Width to 12cm, close 
Property Sheet. 

• Put mouse on rhs of design grid and drag to make form width 13.3cm 

• Switch to Form view, check a few records, click Save. 

 



COMP1000  © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Access Chapters 3+4  slide 28  

Forms Demo 8 

Add Calculated Control to Form 

• Switch to Design view. Place mouse on top edge of Form Footer 
bar, drag down until Detail section is 10cm. Click Controls > Text 
Box, then click just below the NetRevenue text box at bottom of 
Detail. 

• Click in the text box, type =[Quantity]*[Cost]. Press Enter. 

• Open Property Sheet, click All, click in Name box, type 
CostOfOrder. Format=Currency, Text Align=Left. Switch to Form, 
inspect. 

• Switch to Design view, click Label control for CostOfOrder, set 
Caption to Cost of Order. Resize if necessary. 

• Click calculated control, click Other tab on Prop Sheet, Tab 
Stop=No 

• Switch to Form view. Tab through a record or two to see how 
tabbing doesn't stop at the calculated control value. 

• Save the form. 
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Forms Demo 9 

Add Styling to Form 

• Switch to Design view. 

• Open Property Sheet if necessary, then click the Revenue Form 

label. Click the Back Color arrow on the Property Sheet Format tab, 

and choose Access Theme 2. Then set Special Effect to Raised. 

• Click Center in the Text Formatting group on the Ribbon. 

• Click just above the Quantity bound control box on the grid, drag 

through all but Cost of Order, set Special Effect to Sunken. 

• Click Cost of Order, Border Width=2pt. Close Property Sheet. 

• Click Format > Font > Background Color (bucket) arrow, select 

Light Gray 2 (Standard colors3,1). Click Cost of Order label, Font 

Color arrow=Light Gray 4 (Standard colors5,1).  

• Switch to Form view, check it out, File > Compact & Repair 

Database 
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Creating & Using 

Reports 

Based on slides by 

Robert Grauer, Keith Mast, Mary Anne Poatsy 
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Objectives 

Learn how to… 

• Create reports using report tools 

• Modify a report 

• Sort records in a report 

• Identify report sections 

• Revise reports using report views 

• Identify control types in reports 
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Report Basics 

• Report — a printed document that displays 

information from a database in a format 

that provides meaningful information to its 

readers 

Steps: 

• Identifying a record source 

• Choosing a Report tool 

• Modifying a report 
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Questions before Creating a 

Report 

• What is the purpose of the report? 

• Who will use the report? 

• Which tables are needed for the report? 

• What fields, labels, and calculations are 

needed? 

• How will the report be distributed? 

• Will the results be converted to Word, 

Excel, HTML, or another format? 
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Creating Reports using Report 

Tools 

• Access Report Tools 

to create reports 

– Report Tool 

– Report Design 

– Blank Report 

– Report Wizard 

– Labels Tool 

 

 

• Modify existing report 

by using: 

– Layout View, or 

– Design View 
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Identify the Record Source 

Can  be… 

• One or more tables 

• Queries 

• Combinations of tables and queries 

• Can also contain graphics including 

– Company Logos 

– Watermarks 
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Sketch the Report 
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Use the Report Tool 

Report is 

constructed 

with the 

Report tool 

Information 

is presented 

in tabular 

format 
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Use the Report Wizard 

• The Report Wizard asks questions 

– Uses 6 dialog boxes to collect information 

• Then it generates the report based on 

answers 

• The report design can later be modified 
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Starting the Report Wizard 

Select a 

table or 

query 

Select fields 
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Add Grouping to the Report 

Wizard 

Access adds 

StudyID 

automatically 

Add a group 

Select a 

field to 

group by 

Remove a group 
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Add Sorting and Summary 

Options 

Choose Ascending or 

Descending order 

Choose the sort fields 

Click Summary Options to 

add aggregate functions 



COMP1000  © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Access Chapters 3+4  slide 42  

Choose the Layout of the Report 

Choose the Orientation 

Choose the Layout 

Adjust field widths 

so fields fit on one 

page wide. 
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Save and Name the Report 

Type a report name 

Click Finish and you'll 

also see the report in 

preview 

Click "Preview the report" 

to see what it will look like 
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Previewing the Report 
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The Label Wizard 

• Click a Table or Query, then click 

Reports > Labels 

• Wizard 

guides you 

through 

choice of 

label, font, 

fields to print, 

& how to sort 

the data.  
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Modifying a Report 

• Add a Field to a Report 

– Tabular layout 

– Stacked layout 

• Delete a Field from a Report 

– Tabular layout 

– Stacked layout 
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Modifying a Report (continued) 

• Adjust Column Widths in a report 

Layout or Design view. Click on text box, grab 

orange border and drag. 

• Add a Theme to a report 

Layout view. Click Design > Themes > Theme, 

choose a theme, click it. 
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Sorting Records in a Report 

Select FirstName for 

the second sort 

LastName is the 

first sort 

Report comes sorted, 

usually on primary 

key. This can be over-

ridden in the report. 
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Report Demo 1 
• Open a04h2coffee_demo and rename as a04h3coffee_demo 

Using the Report Tool 
• Select the Products table. Click Create > Reports > Report 
• Print Preview it. Too wide. Page Setup > Landscape. Print Preview. 
• Close and Save report as Products. 

Add a Field to a Report 
• Open Products table, change to Design view. 
• Click MarkupPercent field, then click Tools > Insert Rows. 
• Type OnHand in Field Name box, Number as Data Type. In Field 

Properties at bottom, change Field Size to Integer. Add sample 
data: 10#6, 25#2, 55, 40, 55, 125, 75, 200#3, 75#2, 42#2, 175#2, 
22, 37. 

• Close table, open Products report in Layout view. Collapse Nav 
pane. 

• Click Design > Tools > Add Existing Fields. Drag Onhand to 
Products report after Cost. Close Field List pane. 

• Insert a space in the OnHand label control in the Report Header. 
• Display the report in Print Preview. Still too wide. . Save report. 
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Report Demo 2 

Delete a Field from a Report; Adjust Column Widths 
• Close Print Preview. 
• Scroll right. Right-click in Year Introduced column (only works 

in Layout & Design view), press Delete. 
• Click ProductID heading, drag right border to remove waste 

space. 
• Click Refrigeration Needed heading, change to Refrig?, drag 

border. 
• Reduce widths of other fields until it fits on one page. 
• Check Print Preview, close, save the report. 

Apply a Theme to the Report 
• Click Themes > right-click Solstice (2–, 2), Apply Theme to 

This Object Only. Preview/close. File>Save Object 
As>Products Solstice, OK, click File tab. 

• Repeat with Module theme (7,1), Preview/close, Save Object 
As Products Module, OK. Click File tab. 
 



COMP1000  © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Access Chapters 3+4  slide 51  

Report Demo 3 
Change Sorting in a Report 
• Click Grouping & Totals > Group & Sort, click Add a sort button, 

select ProductName from the list. Preview/close. Save & close 
report. 

Use the Report Wizard 
• Open Nav pane if necessary, select Revenue query, Create/Report 

Wizard. 
• Click >> to add all to Selected Fields. Click Cost, then < to remove 

Cost field. Also remove MarkupPercent, LastName, and 
ProductName fields. Click Next. 

• Select City, click >, click Next. 
• Select OrderDate. Click Summary Options. Click Sum for the 

Revenue field. Click Calculate percent …, click OK. Click Next, 
twice. 

• Type Sales by City as the title, click Finish. Inspect, close Print 
Preview. 

• In Layout view, adjust controls so all field values are visible. Click 
Revenue total field, open Property Sheet, select Currency format. 

• Preview/close. Close and save report. Compact & Repair Database. 
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Identifying Report Sections 

Report header 

Page header 

Detail 

Page footer 

Report footer 
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Adding a Group Header/Footer 

Click Group & Sort 

to add grouping 

Specialization group 

header section 

Specialization 

group 

footer section 

Modify the 

grouping & 

sorting 
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Add Totals to a Group Footer/ 

Report Footer 

Total revenue 

is shown at the 

bottom of each 

sales rep 

Count is shown 

at the bottom of 

each sales rep 
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Report Sections 

Section Location Frequency Typical Use Default 

Report 
Header 

Top of 
report 

Once Report title, organization or author name, logo, 
run date and time 

On 

Page 
Header 

Top of 
each page 

Once per 
page 

Column headings On 

Group 
Header 

Top of 
each group 

Once per 
group 

Identifying information for group: e.g. state 
name, course name, or type of employee 

Off 

Detail Middle Once per 
record 

Field values for each record in the source table 
or query. 

On 

Group 
Footer 

End of 
each group 

Once per 
group 

Summary info for group, e.g. state total, 
number of students or employees 

Off 

Page 
Footer 

End of 
each page 

Once per 
page 

Page numbers On 

Report 
Footer 

End of 
report 

Once Grand totals and other aggregate information On 
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Revising Reports Using Report 

Views 

• Layout View 

Sort of WYSIWYG 

• Print Preview 

• Design View 

Useful for long reports 

• Report View 

Un-paginated 
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Identifying Control Types in 

Reports 

• Types of control: 

– Bound controls (connected to a table or query field) 

– Unbound controls (e.g. text labels) 

– Calculated Controls 

• To add a Calculated control to a report 

– Use Design view 

– Add a text box at the desired location. 

– Enter expression to do the calculation: =… 

– Format as needed 
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Report Demo 4 
• Open a04h3coffee_demo and save with h3  h4 

Identify default report sections and add a group header 

• Open Sales Rep table. Add your name to sales rep S0002, close 

table. 

• Open Customers table. Change SalesRepID for Buckingham to 

003. 

• Close. Select Revenue query, click Create > Report Wizard. 

• Add LastName, City, Revenue, OrderDate, & ProductName fields. 

Click Next 4 times. Type Monthly Revenue by Salesperson as 

report title, click Finish, inspect preview, close preview. 

• Click Group & Sort, click Add a group, select LastName. Close 

G&S. 

• Bold all column headings (Format > Font > Bold). Select Last 

Name column heading, type Sales Rep. 

• Modify column positions so columns are equally spaced. 

• Preview, close, save report. 
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Report Demo 5 

Add totals to a group footer/report footer in Layout view 

• Click Revenue field, click Grouping & Sorting>Totals, select 

Sum. 

• Print Preview, check a couple of pages, close. 

• Click City field, click Grouping & Totals > Totals, select Count 

Records. Scroll down until first totals is visible, adjust field 

width for City count if necessary, click Revenue total, open 

Property sheet, click Format arrow, select Currency. Ditto 

grand total at foot of report. 

• Print preview, check whole report, close. 

• Switch to Design view, check out all 7 report regions. 

• Save the report. 
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Report Demo 6 
Work with controls in Design view 
• Click the Monthly Revenue by Salesperson label in the Report 

Header. Press  enough times to make room for another label. 
• Click Design > Controls > Label, click just above the M of 

Monthly…, type Santiago Coffee Shop, press Enter. 
• Click the Format tab, do Font Size 14, Style Italic, Font Color 

Dark Blue, Text 2, Darker 25%, (5,4)-position, then resize the 
box so all is visible. 

• Click LastName text box in LastName Header, Font Size 12, 
Font Color Dark Blue, Text 2 (1,4)-position, Bold, Center, 
background color Yellow. 

• Resize if necessary.  Click Count control in Report Footer, shift-
click Sum control, Bold, Background Color Blue, Accent 1, 
Lighter 80%, (2,5)-position in Theme Colors. 

• Print Preview, review all, close. 
• Save report. 
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Report Demo 7 

Add a calculated control to a report in Design view 

• In Design view, click OrderDate box, press Delete, then delete 

OrderDate label. Drag ProductName box and label to 11.4cm mark. 

• Click Design > Controls > Text Box. Click in Detail section to right of 

ProductName. You get a label for free – select and delete it. 

• Click Tools > Property Sheet. Click in the new box. Click the All tab in 

the Property Sheet, type MinimumOrder in the Name property box 

and ="minimum" in the Control Source property box. Change the 

Border Style to Transparent. 

• Check Print Preview, everything shows "minimum". Close preview. 

• Click the Control Source, press Shift-F2, change the expression to 

=Iif(Revenue<10, "minimum", ""), click OK. 

• Click the MinimumOrder control, Bold, Font Color=Red. 

• Print Preview, check all, close preview, close and save report. 

• File > Compact & Repair Database. 
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Aligning Objects 

• An issue in designing a form or report is 

getting the boxes aligned, so the form or report 

looks neat. 

• To align two (or more) objects in Design view: 

– click the first object, then shift-click the other(s) 

– click the Arrange tab, find the Sizing & Ordering 

group, click Align, then select the kind of alignment 

you want (Left, Right, Top, or Bottom) 

– if you click one or more objects, you also have the 

option of aligning it to the grid. 

• To get boxes A & B to be the same height or 

width – look up this info in box A's Property 

Sheet, and copy to box B's Property Sheet. 
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Summary 

• In this section, you learned how to create 
forms using form tools, modify a form, sort 
records in a form, identify form sections, 
revise forms using form views, and identify 
control types in forms. 

• You also learned how to create reports 
using report tools, modify reports, sort 
records in a report, identify report sections, 
revise reports using report view, and 
identify control types in reports. 


