[prev] [index] [next]

Warning: Notation Change

From now on, we use the following function names:

// return depth of Tree (was TreeDepth)
int depth(Tree t) { ... }

// return #nodes in Tree (was TreeNumNodes)
int size(Tree t) { ... }

// return #nodes in Tree (see later)
int count(Tree t) { ... }

This amounts to changing the Tree ADT interface ... bad for clients.